AX Classic EqEmulator Forums

Source and database discussion for AX_Classic


It is currently Wed Oct 18, 2017 10:49 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 


 Post subject: Group Crash - Bots + PC
PostPosted: Wed Oct 11, 2017 4:59 am 
Forum Moderator Team
Forum Moderator Team
Joined: Tue Jun 03, 2014 1:12 pm
Posts: 166
Location: LGuk - Lord / Hand / Magi
Offline
I'm creating this thread with the understanding that PCs + bots are not fully functional but thought I'd throw it out there as a new thread that only deals with crashes involving both.

Steps as follows (this doesn't happen 100% of the time but more often than not)

1. Group with PC
2. Add bot - for instance adding a bot, then porting.
3. Drop bot after port.
4. Zone to a different zone. At this point the group will show the previous bot (one who ported as if it were in the group but not in zone even though it was disbanded).
5. Add new bot - at this point this will crash the zone. This doesn't happen all the time and it doesn't crash, when zoning again, if that bot had been dropped, then you have 2 former 'grayed' out bots in group.

To get around this I have just been disbanding the group when changing bots and reforming. Haven't had the issue when doing that. I remember seeing old bots stick around back when we could fill out a group with 2 PCs and 4 bots so I imagine this is just remnants of that.

_________________
- Wraith / Cassius / Serato
Prexus: Silenced (Keepers of the Faith)


Top
 Profile  
Reply with quote  

 Post subject: Re: Group Crash - Bots + PC
PostPosted: Wed Oct 11, 2017 7:43 am 
Developer Team
Developer Team
Joined: Sun Sep 16, 2007 10:16 am
Posts: 4129
Location: Cript of Nadox
Offline
Thanks for the info - have you had any of this happen yesterday?
Also, is these all due to grouping with other clients and combining bots?

_________________
"Damn my eyes! You're just another mirage!"
...Memories of 'a madman' from Oasis of Marr


Top
 Profile  
Reply with quote  

 Post subject: Re: Group Crash - Bots + PC
PostPosted: Wed Oct 11, 2017 10:39 am 
Forum Moderator Team
Forum Moderator Team
Joined: Tue Jun 03, 2014 1:12 pm
Posts: 166
Location: LGuk - Lord / Hand / Magi
Offline
Yesterday I don't think I forgot to disband group at any point and thus crash the zone. I will try to reproduce it today and verify the steps.

Both clients are Underfoot. I'm always the group leader and the one to spawn the bot (on Wraith).

The giveaway that reminds me to disband is seeing the 'inactive' bots in the group window. A note on that (if there are inactive bots), I haven't tried it lately but I do recall if I disbanded without having myself targeted, that would also crash the zone. I will also try to reproduce this today.

_________________
- Wraith / Cassius / Serato
Prexus: Silenced (Keepers of the Faith)


Top
 Profile  
Reply with quote  

Display posts from previous:  Sort by  

Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group